User Interface Degraded

Incident Report for Airo App Builder

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 08:55 UTC

Investigating

We are currently investigating an issue that may affect the UI within the Airo App Builder.
Posted Jul 21, 2026 - 06:27 UTC
This incident affected: UI (North America, Europe).