Airo Builder Degraded Dashboard

Incident Report for Airo App Builder

Resolved

This issue has been resolved.
Posted Sep 09, 2026 - 07:49 UTC

Investigating

We are currently investigating an issue causing the Airo AI App Builder Analytics tab to show inaccurate data for some customers.
Posted Sep 07, 2026 - 11:41 UTC
This incident affected: UI (Europe).